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Introduction to Advance for Office

What is Advance for Office?

Advance for Office is the collective name of a number of facilities that enable you 
to embed and create Advance requests within Microsoft Office. These facilities 
extend the functionality of Microsoft Excel, Word and PowerPoint so you can 
retrieve and display data directly from Datastream without the need to use 
Advance. These facilities bring the ease-of-use and power of Advance directly into 
your everyday use of Microsoft Office.

Practical uses of Advance for Office

Advance chart requests can be embedded into 
Microsoft Word to provide you with dynamic, 
refreshable documents which could be reports, studies, 
presentations, or any document you want to create.

The Advance for Office Add-Ins give you a host of data request creation and 
management facilities available for selection from the Excel, Word, and PowerPoint 
main menus. Once you have created your data requests, they can remain as 
embedded, editable and refreshable objects.

You can transfer any Advance chart directly to 
PowerPoint to compile a slide presentation. There is no 
need to transfer the charts again to keep your 
presentation up-to-date as the Autorefresh feature will 
update all embedded charts.
Datastream Advance for Office version 4, Issue 1 5
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Advance for Office core features

The Add-Ins to Microsoft Excel, Word, and PowerPoint, available with Advance 4, 
provide the following features:

� Transfer data and chart requests to Excel and chart requests to Word and 
PowerPoint as dynamic refreshable objects. Dynamic chart and data objects can 
be refreshed when the document is opened (Autorefresh) or when you choose to 
update them (Refresh). 

� Creation of static, time series, and company accounts data requests in Excel, 
Word, and PowerPoint with series and datatype selection facilities. You can 
access the same global and user created expressions (for static data requests 
only), and company accounts formats that are available in Advance.

� Facilities to resize and reposition charts in Excel, Word, and PowerPoint.

� Time series data can be returned for constituents of local lists stored on your PC, 
and for Datastream lists and user created lists stored on Datastream. Time series 
requests for constituents of lists are issued as a single request.

� You can use the Request Manager to view and edit the properties of all 
embedded data and chart objects in Excel, Word, and PowerPoint. You can 
choose to refresh or delete individual requests or all requests that are embedded 
in a document.

� The Request Table enables you to create and easily maintain many requests 
from Datastream in Excel without writing VBA code. Request tables could contain 
all your regularly used data requests and can be scheduled to be processed ‘out 
of hours’ or processed just when you want the results. 

� A conversion wizard is provided to convert your existing DSDDE request tables 
into Advance for Office tables. The wizard also enables you to convert DSDDE 
linked workbooks into Advance for Office data controls or Advance for Office 
request tables.

� You can view and edit the properties that make up your embedded requests by 
using Visual Basic for Applications (VBA) which comes with Excel, Word, and 
PowerPoint.
Datastream Advance for Office version 4, Issue 1 6
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What’s new in Advance for Office 4

� Central Navigation
Advance for Office now uses the new Datastream Navigator central navigation 
database for finding series and datatypes. This means that you will no longer 
need to update the local codes database as this will be done centrally.

� MS Chart facilities
You are now able to display your requests as MS Charts in Word, Powerpoint and 
Excel.

� Request Table Formatting
The formatting options in the request table have been extended to support the 
display of titles or the first series of expressions. Details of the time and duration 
of each request update have also been added.

� Request Table VBA Macros
A new facility has been added to the request table to allow you to specify an Excel 
VBA Macro to run after the request table has finished updating, this could be used 
to sort or print the output. 

� Chart Transfer
Additional chart transfer options have been added to the Advance Tools Options 
to enable you to set the default size of a chart and whether you would like the 
chart to be transferred as an Office Picture. The background can also be set to 
transparent.
Datastream Advance for Office version 4, Issue 1 7
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Installing Advance for Office

System requirements

In addition to Advance 4, you need to have Microsoft Office 2000 installed before you 
can run Advance for Office. All Advance for Office software components are installed 
when you install Advance 4. 

Full system requirements are given in the Advance Technical Facts.

Installation

Advance for Office is a set of Add-In components for Excel, Word and PowerPoint. 
When installing Advance 4, the Add-In components for Excel (AdvanceOffice.xla), 
and PowerPoint (DSAFO4PP.PPA) are installed automatically. The Add-In for Word 
(AFOWord.dot) has to be copied to the Office startup directory. The installation 
configuration you choose for Advance 4 determines where the Add-In components are 
installed, this could be:
� Install to this PC - installs a full copy of Advance onto your PC’s hard drive.

� Install client from server - installs a reduced set of files, leaving remainder on 
the server.

To use Advance for Office, after Advance 4 has been installed, you need to locate the 
relevant add-in component and open it within Excel, Word or PowerPoint. 

Note:
Wherever you install the Advance for Office.xla you must make sure that the request table 
template (Adv_xl.xlt) is in the same directory location.
Datastream Advance for Office version 4, Issue 1 8
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Installing the Microsoft Excel Add-In

Before installing the Excel Add-In, AdvanceOffice.xla, you must ensure that you have 
installed Advance 4.

Loading the Add-Ins using Fast Load

After installing the Add-In, you can select the Fast Load option from the Datastream-
AFO>Options menu to speed up the initial load time. 

There are three ways in which you can open the Advance for Office Add-In component 
for Excel. Each method has a different impact on the way you use Excel.
� Permanent Add-In

This method loads the AdvanceOffice.xla each time you launch Excel, making 
the Advance for Office facilities always available from the Datastream-AFO 
menu. 

To select this method:

1 Run Excel from the Windows Start menu.
2 Select Add-Ins... from the Tools menu. 

The Add-ins dialog is displayed.
3 Click the Browse button and navigate to the Datastream Advance directory, select 

AdvanceOffice.xla, and click OK.
4 Click the Advance Office check box.
5 Click OK.

� File open
This method opens the AdvanceOffice.xla like any other spreadsheet, enabling 
you to launch the Advance for Office facilities only when you want them.

To select this method:

1 Select the Open option from the File menu.
2 Navigate to the Datastream Advance directory and select AdvanceOffice.xla
3 Click Open
Datastream Advance for Office version 4, Issue 1 9
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� Fast load
This method makes the Datastream-AFO menu available (and its options) for 
selection without loading the facilities each time you launch Excel. The .xla 
component is only loaded when a Datastream-AFO option is selected, enabling 
Excel to load faster upon start-up.

1 Follow the steps for Permanent Add-In above.
2 Select Options from the Datastream-AFO menu.
3 Click the Fast Load check box on the Options screen.
4 Click OK.
Datastream Advance for Office version 4, Issue 1 10
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Installing the Microsoft Word Add-In

Before installing the Word Add-In, AFOWord.dot, you must ensure that you have 
installed Advance 4.

1 Navigate to where you installed Advance on your PC (or server). The default 
directory for the Advance 4 installation is C:\Program Files\Datastream\ 
Datastream Advance. 

2 Copy the Word Add-In, AFOWord.dot, to the Office Startup directory. (The default 
directory is C:\Program Files\Microsoft Office\Office\Startup.) 

The Add-In is now installed. When you run Word you should see the Datastream-AFO 
menu on the main Word menu bar. Use this menu to select all the Advance for office 
facilities within Word.
Datastream Advance for Office version 4, Issue 1 11
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Installing the Microsoft PowerPoint Add-In

Before installing the PowerPoint Add-In, DSAFO4PP.PPA, you must ensure that you 
have installed Advance 4.

1 Select Add-Ins... from the PowerPoint Tools menu. The Add-Ins dialog is 
displayed.

2 Click the Add New... button to display the Add New PowerPoint Add-In dialog.
3 Navigate to where you installed Advance on your PC (or server) using the Look in 

list. The default directory for the Advance 3 installation is C:\Program 
Files\Datastream\Datastream Advance

4 Click on the PowerPoint Add-In DSAFO4PP.PPA and click OK. The add-in is 
displayed on the Add New PowerPoint Add-In dialog. Click OK to confirm use.

The Add-In is now installed and you should see the Datastream-AFO menu on the 
main PowerPoint menu bar. You will use this menu to select all Advance for Office 
facilities within PowerPoint.
Datastream Advance for Office version 4, Issue 1 12
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Using the Datastream Advance Connection Manager

Once you have installed Advance 4 and have setup your Advance for Office Add-Ins, 
you may need to configure your Datastream logon ID and communications profiles. 
This can be done in Advance by using the Configure Communications option from 
the Tools menu. Full documentation is provided on this option in the Reference 
section of the Advance User Guide.

Access to this option can also be obtained in Excel, Word, and 
PowerPoint when the Advance for Office Add-Ins are loaded, by 
right clicking the lightning symbol in the Windows system tray.

When you right click the lightning symbol, the Connection Manager pop-up menu is 
displayed presenting you with a number of communications related options:

� Force Exit - this option closes the Connection Manager but leaves the 
Datastream Communications Server running if it is being used by Advance.

� Force Exit and Shutdown Comms Server - this option shuts down the 
Datastream Communications Server preventing any further communications with 
Datastream. When you select this option, the Connection Manager facilities 
(described here) will no longer be active. The Connection Manager and 
Communications Server will restart when you next make a request.

� Error Log - this option displays the Datastream Communications Server error 
log in Windows Notepad format. The error log contains historical details of the 
date, time and description of the communications error. This error log may be 
required when reporting communications failures to Datastream support staff.

� Show Interactive Terminal - this option is for expert users who want access to 
the Datastream Research Service via MS Office, for example to create company 
accounts formats.

� Show Gateway Monitor - This option enables you to view gateway information 
when you are queued in a gateway after making a request. You can use it to view 
the maximum number of user connections to Datastream, the number of currently 
connected users and the number of users queued.
Datastream Advance for Office version 4, Issue 1 13
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� Connect Now - this option enables you to test your communications connection 
to Datastream. When you issue a data request, the connection is automatically 
made. This option enables you to test out the connection and view the connection 
details, via the DSAccess Debug Monitor, without issuing a request. Connection 
errors are reported in the Error Log (see above).

� Disconnect from Datastream - this option disconnects the communications link 
between Advance for Office and Datastream but leaves the Connection 
Manager and the Datastream Communications Server running. This might be 
useful if you want to send another request in the same MS Office session.

� Configure Communications... - this option enables access to the Datastream 
Configuration dialog which is used to set up the Datastream logon and 
communications configuration details. Full details of this dialog can be found in 
the Reference section of the Advance User Guide.

� Cancel Pending Datachannels... - this option cancels any Data Channel 
requests that are queued.

� Suppress Autorefresh of Embedded Requests - this option overrides the 
automatic refresh setting of any embedded requests.
Datastream Advance for Office version 4, Issue 1 14
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Reference

VBA Developers Workbench for Advance for Office

Experienced users/developers can interface to any of Advance for Office’s underlying 
functionality via utilising its ActiveX components. The user can use any COM enabled 
programming language (such as Excel Visual Basic, Microsoft Visual Basic or Delphi) 
to embed and request data and chart requests programmatically in any Microsoft 
Office application.

Examples for this advanced facility can be downloaded from the Datastream customer 
support Extranet site:

http://extranet.datastream.com
You will need, however, to be a Datastream user and have a Datastream logon ID and 
password, and have access rights to this extranet site. Applications for access to this 
site should be addressed to:

www.datastream.com/registration/registfm.htm

Advance for Office samples

A host of pre-formatted Advance for Office templates are available for downloading 
from the Datastream Extranet (see above). These templates include Excel 
spreadsheets with embedded AFO data requests and Request Tables, and Word 
documents with embedded charts. These samples contain parameters that can be 
changed using the Advance for Office facilities.
Datastream Advance for Office version 4, Issue 1 15
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Converting DDE Request Tables for Datastream AFO

A Conversion Wizard is supplied with Advance for Office for users of DSDDE 2.0 
(and above) who want to convert DDE Request Tables and DDE linked workbooks for 
use with Advance for Office. Five conversion types are available:

� Conversion of DDE Request Tables into Advance for Office Request Tables. 
Multiple tables can be converted in one go but are converted on a one for one 
basis.

� Conversion of Excel workbooks with DDE linked requests into an Advance for 
Office Request Table. Each DDE linked request becomes a new row in the 
Advance for Office Request Table.

� Conversion of DSDDE linked workbooks into workbooks containing Advance for 
Office data controls. Multiple DDE linked requests can be converted in one go.

� Conversion of AFO embedded requests to AFO request table.
� Conversion from AFO 2.0 request tables to AFO 3.5 request tables in order to use 

chart requests and the code button options.

Converting DDE Tables to AFO Request Tables

1 Select Conversion Wizard from the Datastream-AFO>Request Table menu.
2 Click the Convert DDE Table to Request Table option, as shown below.
Datastream Advance for Office version 4, Issue 1 16
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3  Click Setup to display the Setup Options screen. Enter the path on your PC 
where the Advance for Office Request Table template (Adv_xl.xlt) resides and click 
the backup option check box. For example:

4 Click OK to close Setup Options.
5 Click Next.
6 Click Add and navigate to where the DDE tables you wish to convert are located. 

Select the required tables and click OPEN. The tables you have selected will 
appear in the conversion wizard, for example:

7 Repeat step 6, if you require more tables to be converted. Click Next and then click 
Finish.

8 You are now asked to confirm the conversion. Click OK.
9 The message now appears - Pasting new request into Request Table. When the 

conversion process is complete, the message appears Finished, no conversion 
errors encountered. Click OK to quit the Conversion Wizard.
Datastream Advance for Office version 4, Issue 1 17
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Converting DDE linked requests into an AFO request table

1 Select Conversion Wizard from the Datastream-AFO>Request Table menu.
2 Click the Convert DDE Links to Request Table option.
3 Click Setup to display the setup screen. Enter the path on your PC where the 

Advance for Office Request Table template (Adv_xl.xlt) resides and click the 
backup option check box.

4 Click OK to close Setup Options.
5 Click Next.
6 Click Add and navigate to where the Excel workbooks that contain the linked DDE 

requests are located. Select the required .XLS workbooks and click OPEN. The 
workbooks you have selected will appear in the conversion wizard.

7 Click Next and then click Finish.
8 You are now asked to confirm the conversion. Click OK. The conversion process 

now starts.
9 When the conversion process is complete, the message appears - Finished, no 

conversion errors encountered. Click OK to quit the Conversion Wizard.

Converting DDE linked requests into AFO Excel embedded requests

1 Select Conversion Wizard from the Datastream-AFO>Request Table menu.
2 Click the Convert DDE Links to AFO Data Controls option.
3 Click Next.
4 Click Add and navigate to where the Excel workbooks that contain the linked DDE 

requests are located. Select the required .XLS workbooks and click OPEN. The 
workbooks you have selected will appear in the conversion wizard.

5 Click Next and then click Finish.
6 You are now asked to confirm the conversion. Click OK. The conversion process 

now starts.
7 When the conversion process is complete, the message appears - Finished, no 

conversion errors encountered. Click OK to quit the Conversion Wizard
Datastream Advance for Office version 4, Issue 1 18
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 Converting AFO embedded requests to AFO request tables

1 Select Conversion Wizard from the Datastream-AFO>Request Table menu.
2 Click the Convert AFOdata controls to Request Table option.
3 Click Setup to display the setup screen. Enter the path on your PC where the 

Advance for Office Request Table template (Adv_xl.xlt) resides and click the 
backup option check box.

4 Click OK to close Setup Options.
5 Click Next.
6 Click Add and navigate to where the Excel workbooks that contain the AFO 

embedded links are located. Select the required .XLS workbooks and click OPEN. 
The workbooks you have selected will appear in the conversion wizard.

7 Click Next and then click Finish.
8 You are now asked to confirm the conversion. Click OK. The conversion process 

now starts.
9 When the conversion process is complete, the message appears - Finished, no 

conversion errors encountered. Click OK to quit the Conversion Wizard.

Upgrading AFO 2.0 request tables to AFO 4 request tables 

1 Select Conversion Wizard from the Datastream-AFO>Request Table menu.
2 Click the Upgrade AFOdata Request Table to latest version option.
3 Click Setup to display the setup screen. Enter the path on your PC where the 

Advance for Office Request Table template (Adv_xl.xlt) resides and click the 
backup option check box.

4 Click OK to close Setup Options.
5 Click Next.
6 Click Add and navigate to where the Excel workbooks that contain the AFO 2.0 

Request tables are located. Select the required .XLS workbooks and click OPEN. 
The workbooks you have selected will appear in the conversion wizard.

7 Click Next and then click Finish.
8 You are now asked to confirm the conversion. Click OK. The conversion process 

now starts.
9 When the conversion process is complete, the message appears - Finished, no 

conversion errors encountered. Click OK to quit the Conversion Wizard.
Datastream Advance for Office version 4, Issue 1 19
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